27 lines
603 B
Nix
27 lines
603 B
Nix
{
|
|
lib,
|
|
stdenv,
|
|
}:
|
|
stdenv.mkDerivation {
|
|
pname = "mcmojave-xcursor";
|
|
version = "0.1";
|
|
src = ../.;
|
|
|
|
# Shamelessly copied flake from https://github.com/Libadoxon/mcmojave-hyprcursor/blob/main/nix/default.nix
|
|
|
|
installPhase = ''
|
|
runHook preInstall
|
|
|
|
mkdir -p $out/share/icons/
|
|
mkdir -p $out/share/icons/McMojave-cursors
|
|
cp $src/dist/* -r $out/share/icons/McMojave-cursors
|
|
|
|
runHook postInstall
|
|
'';
|
|
|
|
meta = with lib; {
|
|
description = "The McMojave xcursor theme packaged for NixOS";
|
|
license = licenses.gpl3;
|
|
maintainers = with maintainers; [ Nickiel12 ];
|
|
};
|
|
}
|